Уязвимость в BMC-контроллере Supermicro позволяет получить доступ к паролям управляющего интерфейса

В BMC (Baseboard Management Сontroller) чипе, используемом в материнских платах Supermicro, выявлена уязвимость, позволяющая злоумышленнику получить доступ к паролям входа в управляющий интерфейс. Проблема вызвана тем, что содержимое файла с паролями выводится среди бинарного блока данных, который можно получить без аутентификации через сетевой порт 49152. Техника эксплуатации очень проста, достаточно подключиться к порту 49152 и…

Подробнее

Ubuntu индикаторы CapsLock, NumLock, ScrollLock

Приобрел сегодня прикольный комплектик a4tech 9500h, как на фотке выше, все круто, один минус, что из-за компактности нет индикаторов CapsLock, NumLock, ScrollLock, под виндой ставится драйвер и там прекрасно отображается статус на экране, но мы же не виндузятники, чтож, поставим индикаторы для убунты. sudo add-apt-repository ppa:tsbarnes/indicator-keylock sudo apt-get update sudo apt-get install indicator-keylock Alt+F2 и…

Подробнее

Debian установка node.js

nodejs
Установка node.js под Debian

apt-get install python g++ make checkinstall fakeroot
src=$(mktemp -d) && cd $src
wget -N http://nodejs.org/dist/node-latest.tar.gz
tar xzvf node-latest.tar.gz && cd node-v*
./configure
make install

также легким движением руки устанавливаем npm

curl https://www.npmjs.org/install.sh | sh

проверим

# node -v
v0.10.28
# npm -v
1.4.14

CentOS 6.x php 5.2

php
Раньше можно было взять его на атомике, сейчас в репозитории потерли старые пакеты, выход нашелся, установить можно отсюда

baseurl=http://yum.mchost.ru/pub/php52/centos/6/x86_64/
enabled=1
gpgcheck=1

не забываем в
/etc/yum.repos.d/CentOS-Base.repo
в [base] и [updates] добавить
exclude=php*

yum install php --nogpgcheck

Windows, установка Zabbix агента

Давно хотел запостить пример установки заббикс агента под виндой, да все руки не доходили, сегодня решился это сделать 🙂 Качаем агента по сцылке http://www.zabbix.com/ru/download.php в разделе Pre-compiled Zabbix 2.2.1 (stable) agents are available for selected platforms далее устанавливаем его, для этого, создадим например на диске C: директорию Zabbix и распакуем в нее из архива, который…

Подробнее

Zabbix, правила преобразования значений для шаблонов мониторинга vmware

Шаблоны для мониторинга VmWare хостов можно слить на оффсайте заббикса https://www.zabbix.org/wiki/Zabbix_Templates/Official_Templates для их работы необходимы следующие преобразования значений VMware VirtualMachinePowerState 0 ⇒ poweredOff 1 ⇒ poweredOn 2 ⇒ suspended VMware status 0 ⇒ gray 1 ⇒ green 2 ⇒ yellow 3 ⇒ red необходимые маркосы {$URL} — VMware service (vCenter or vSphere) URL (https://servername/sdk) {$USERNAME}…

Подробнее

VmWare esxi 5.x enable snmp

Логинимся с помощью ssh клиента на esxi хост и вводим ~ # esxcli system snmp set -c public ~ # esxcli system snmp set -e yes ~ # snmpwalk -v2c -c public ~ # esxcli system snmp set —targets xx.xx.xx.xx@161/public ~ # esxcli system snmp test Comments: There is 1 target configured, send warmStart requested,…

Подробнее

Apache, server-status ошибка (13)Permission denied: cannot read directory for multi: /var/www/

apache
Не работал server-status у апача, вываливаясь при запросе в

ERROR 403: Forbidden

а в логе висела ошибка

 [error] [client 127.0.0.1] (13)Permission denied: cannot read directory for multi: /var/www/

Проблема в MultiViews для default-site.
Варианта два, вычистить его конфиг от MultiViews

/etc/apache2/sites-available/default

и передернуть апач, или полностью отключить дефолт сайт

a2dissite 000-default
/etc/init.d/apache2 reload

Remmina «Unable to connect to RDP server 10.10.10.10»

Remmina
Давече столкнулся с проблемой, remmina, матюкнулась мне, мол
«Unable to connect to RDP server 10.10.10.10»
решение простенькое, открываем файл

nano ~/.freerdp/known_hosts

и ищем наш проблемный сервер 10.10.10.10
далее удаляем строку с ним.

Правка реестра Windows XP даёт доступ к обновлениям до 9 апреля 2019 года

Небольшое изменение в реестре может продлить поддержку операционной системы Windows XP до 9 апреля 2019 года, сообщает немецкий хакер Sebijk (http://www.sebijk.com/community/board15-other/board73..).

Дело в том, что Microsoft ещё пять лет будет поддерживать операционную систему Windows POSReady 2009 для банкоматов (http://www.microsoft.com/en-us/news/press/2009/jan09/..), а та основана на Windows XP, так что большинство патчей тоже сохраняют совместимость. Соответственно, для получения свежих апдейтов достаточно всего лишь выдать свою систему за Windows POSReady 2009.

Для этого нужно создать текстовый файл.

Подробнее